GETTING ONLINE with WWW.YOURSHOWROOM.EDU

Updated Oct 30, 2006

Creating a web presence on the UOREGON server using template files requires seven steps: 

1.  Downloading and Saving "Student_Template"

2.  Unzipping the Template Files 

3.  Getting Started with GoLive

4.  Editing Your Homepage

5.  Editing Your Assignment Pages

6.  Uploading Your Student Template

7.  Expanding Your Website with New Assignments

1.  Downloading and Saving "Student_Template"

Step 1:
To download the student template, click the "Syllabus" link at the top of the Architecture 610 homepage.

Step 2:
Click the "6" link in the green banner to go to week 1 of the syllabus.

Step 3:
Click "WWW.YOURSHOWROOM.EDU" to go to assignment 1 of week 1.

Step 4:
On the assignment 6 overview page, click "Assignment Steps".

Step 5:
Here you will find details about assignment 6. Under "Part I: Download, Text Format, Link, Upload", click the "student_template.zip" link. This will download the template that you will use to post your assignments.

Step 6:
Clicking "student_template.zip" will launch the file download window on your system. Click "Save" to save the files on your desktop.

Step 7:
A "Save As" dialog box will appear. Click on the desktop icon to select the directory. Make sure the file name remains "student_template" and click "Save".

Step 8:
Once the download is complete close your browser window.

Step 9:
A zip file called "student_template" should now appear on your desktop.

2.  Unzipping the Template Files on Windows

Step 1:
Find the "student_template.zip" file on your desktop and double click it to open.

Step 2:
Click the "Close" button in the "ZipCentral Tip of the Day" window.

Step 3:
Click the "Extract" button in the toolbar. This will launch the "Extract files..." dialog box.

Step 4:
Click "Browse", select your "Desktop" directory and then click "OK".

Step 5:
Click "OK" again. Your files will begin to extract onto your desktop.

Step 6:
Once your file has completed, close the "ZipCentral" window.

Step 7:
A folder called "student_template" should now appear on your desktop.

3.  Getting Started

Step 1:
In the "student_template" folder you will find the “arch610” folder. In this folder, you will find the following items:

index.html file -
This is the homepage for your course assignments.
arch610.css -
This is the CSS file for your pages. Do not change this file.

template_images folder -
This contains the image files for your index.html. Do not add your assignment images to this folder.

assignment_01 folder -
This contains the template and image folder for assignment 01.

assignment01.html file -
This is the page for your first assignment.

assignment_images folder -
This contains your image files for the assignment and html template.

NOTE: Additional projects should be structured the same as assignment_01 folder.

Steps 2-8: 
To start the tutorial, you'll need to create a site using Adobe GoLive. The steps to create a site vary between GoLive CS and GoLive CS2. Click the “Help” menu and select “About GoLive” to determine the version you have and then follow the appropriate steps.

	
	Adobe GoLive CS
	Adobe GoLive CS2

	Step 2:
	Click on "File" menu and  select "New Site".
	Click on “File” menu and select “New…”

	
	
	

	Step 3:
	The "Site Wizard" window will open to help you structure your site. Choose "Single User" and then click "Next".
	The “New” window will open by default to “Site Creation Wizard”. Choose “Site from Existing Content” and then click “Next”.

	
	
	

	Step 4:
	"Site Wizard" will now display options for the content of your site. Choose "Import from Folder" and then click "Next".
	Choose “From a Local Folder of Existing Files” and then click “Next”.

	
	
	

	Step 5:
	To import the tutorial template, click the first "Browse" button, browse your local desktop for the "arch610" folder and then click "OK".
	To import the template as your site, select the first “Browse” button, browse your local desktop for the “arch610” folder and then click “OK”. 

	
	
	

	Step 6:
	To select the home page for your site, click the second "Browse" button, choose index.html located in the "arch610" folder and click "Open".
	By default, index.html is shown as the home page for your site. That default is good for our purposes.

	
	
	

	
	Adobe GoLive CS (cont’d.)
	Adobe GoLive CS2 (cont’d.)

	Step 7:
	You have now located all of the template files you'll need to begin the tutorial. Click "Next" in the "Site Wizard" window.
	You have now located all of the template files you'll need to begin the tutorial. Click "Next" in the "Site Wizard" window.

	
	
	

	Step 8:
	The "Choose a Location..." dialog window will appear. Choose your copy of the "arch610" folder and type the name of your new site using your UOREGON user name followed by ".site". You may now click "Save".
	Next you’ll be asked to specify a site name and location. By default, your site is set next to the existing content you’ve just set up. Those defaults are good for our purposes.

	
	
	

	Step 9:
	Your site is now set up. Go ahead and click "Finish".
	Your site is now set up. Go ahead and click "Finish".


Step 10:
Now a new window will open displaying your new site directory that is located in your "arch610" folder.

Step 11:
To connect your site to a server so others can view it, click on "Site" and choose "Publish Server". Go ahead and click "Connect".

Step 12:
The "Publish Server Message" window will open and you can click "OK".

Step 13:
The "Site Setting" window will open. Click "Add" in the sidebar.

Step 14:
The "Select Publish Server" will open. Click the "New" button to add your server.

Step 15:
Within the same window, change the "nickname" to your UOREGON user name. This nickname will reference your UOREGON account in GoLive. For the "Protocol" choose "ftp".

Step 16:
Change the "Server" to “shell.uoregon.edu”.

Step 17:
In the "Directory" field type "public_html".

Step 18:
In the "Username" field enter your UOREGON username. In the "Password" field enter your UOREGON password, then click "OK".

Step 19:
In the "Site Setting" window click "OK".

Step 20:
The "Site" window will appear showing a directory of your local drive and a directory of your publishing server. Now you are setup to upload files to your UOREGON account.

Step 21:
The left side of the window is our local desktop. Here you will see the assignment folder that holds your html file and images. Each assignment will have its own folder that you will upload when completed.

Step 22:
On the right side is your account on the UOREGON server. You are looking at the public_html directory in your UOREGON account. This is where you will place all your assignment folder to make them live on your website.

4.  Editing Your Homepage

Step 1:
To get started, copy a digital image of your face to the template_images folder. Use Photoshop to convert the image to GIF or JPG format and resize it to fit into 200 x 200 pixels.

Step 2:
Launch GoLive and open your .site file.  In this example mgable.site is already open. In the "Site" window, double click on the index.html to edit the file.

Step 3:
In index.html, click on the gray box labeled "Your picture goes here".

Step 4:
To add your picture:

· Go to the "Inspector" window (If not open, select the Window menu > Inspector)

· Click the "Basic" tab

· Click the "Source" folder icon to find your picture in the "template_images" folder

· When you have found your picture, click "Open" to place the picture on your homepage.

Step 5:
Replace "Your name goes here" with your own name and replace "your email address goes here" with your UOREGON email account name.

Step 6:
Replace "Welcome statement goes here" with whatever introductory text you want to appear on your homepage.

Step 7:
The numbered icons on the right side of the index.html page will act as links to your assignments. The "1" icon is already linked to assignment01.html file in the student template folder.

Step 8:
To link an icon to an assignment:

· Select the assignment icon which you want to link.

· From the "Inspector" window, click the "Link" tab.

· Click the "Browse" folder icon and select the file you want to link to.

· Click "Open". The assignment icon is now linked to the assignment file.

Step 9:
"Save" your changes.

5.  Editing Your Assignment Pages

Step 1:
To get started, copy your collected assignment images, into the "assignment_images" folder, within "assignment01".

Step 2:
Open the "Inspector" panel by clicking on the "Window" menu and select "Inspector". 

Step 3:
Open your assignment01.html in GoLive.

Step 4:
Replace "Your name goes here" with your own name. Replace "Assignment name goes here" with your assignment title and "Type your statement here" with a description of your assignment.

Step 5:
At the bottom of the page, the icon representing the current assignment 1 should be highlighted. You will need to add highlighted icons when working with assignment02.html – assignment08.html.

Step 6:
To highlight an assignment icon, click the icon at the bottom of the assignment html file.

Step 7:
To highlight your assignment icon:

· Go to the "Inspector" window and click the "Basic" tab

· Click the "Source" folder icon, select assign01_on.gif and click "Open"

· This will change your assignment icon to a highlighted state.

Step 8:
To link the assignment icon at the bottom of the page:

· Select the assignment icon that you want to link.

· From the "Inspector" window, click the "Link" tab.

· Click the "Browse" folder icon and select the file you want to link to.

· Click "Open". The assignment icon is now linked to the assignment file.

· Repeat for assignment icons 2-9 as necessary.

Step 9:
To add assignment images to assignment 1:

· From the "Inspector" window, click the "Basic" tab.

· In the grid, click on a gray box.

· Click the "Browse" folder icon and select the image you want to add. Be sure this image is in your "assignment_images" subfolder within the assignment folders.

· Click "Open". This image will now be added to your assignment.

· Repeat for each image you want to add.

· Delete any gray boxes that you are not adding images to.

Step 10:
"Save" your changes.

6.  Uploading Your Student Template

Step 1:
To upload your files using GoLive, go to the "Site" menu, select "Publish Server" and then select the "Nickname" that you assigned for your UOREGON account.

Step 2:
Once you have selected your UOREGON account, go to the "Site" menu, select "Publish Server" and then select "Connect".

Step 3:
Your site window will appear showing your desktop on the left and the public_html directory of your UOREGON account on the right.

Step 4:
Click on the "Upload Modified Files" icon located on the top in the tool bar menu.

Step 5:
This is your desktop. Inside the assignment 1 folder is the html file which you just modified and the images you added which you want to upload to your website.

Step 6:
This is your UOREGON account. The assignment 1 folder and files you see here are the original, unmodified versions you uploaded when you set up your account on GoLive. These files will be replaced with the modified version that you will upload from your desktop.

Step 7:
Between your desktop files and your UOREGON files is a clickable box. Click this box until a green upload arrow appears. In this example, all files will be uploaded. Once you have selected your icons for each file, click "OK".

Step 8:
The "Synchronize" message window will appear, with the message "Are you sure you want to do the following:" Click "Yes".

Step 9:
Your site window will now be updated with your UOREGON account containing the modified files you just uploaded. You can tell which are the newest versions by looking at the date and time listed under "Modified".

Step 10:
Once you have finished uploading your files, click the "Site" menu, select "Publish Server" and then select "Disconnect".

Step 11:
Open your browser and go to your UOREGON account to view your assignment pages.  In this example you would go to:


http://www.uoregon.edu/~mgable/index.html 

7.  Expanding Your Website with new Assignments

Step 1:
Download the week's "assignment template" and unzip it to a convenient location. See "Downloading Template" and "Unzipping Templates".

Step 2:
In GoLive, open the site you built the first week of class.

Step 3:
In your site, add a new folder on the same level as your index.html file. Label it "assignment02" for assignment two, for example, or some label that you will remember corresponds to the work you're adding.

Step 4:
Copy assignment01.html, paste it into the assignment02 folder and rename it assignment02.html.  Create a new assignment_images folder inside of the assignment02 folder.  Click open the assignment02 folder to be sure assignment02.html and the new assignment_images folder was added to your established site.

Step 5:
Gather the assignment images you've created as part of your assignment. Drag and drop them into the "assignment_images" folder for the week you're adding. Click open the folder to be sure the images were added to your established site.

Step 6:
Open the index.html - your homepage - of your site, by double clicking on the page.

Step 7:
On your homepage, select the icon for the week you are updating ("Week 2" here). In the "Inspector" window, select link. Use the file browser next to the link text to find your assignment02.html file within the assignment02 folder. Click "Open" or double-click and the inspector should read that the graphic links to the file.

Step 8:
Save the index.html page. Open the new assignment page - assignment02.html in this example - within its folder by double-clicking on it in your site directory. "Refresh View" if needed.

Step 9:
Edit the text of assignment02.html for the new page.

Step 10:
Replace the images or broken links with the new images you've created. Select an image icon. In the "Inspector" window under the "Basic" tab, browse for your new assignment images. Click "Open" or double-click to place your image.

Step 11:
Repeat for all the images you have to replace. 

Step 12:
Once your assignment page is how you'd like it to be, save your changes, and post the changes to your UOREGON account. Connect to the Publish Server with Site>Connect.

Step 13:
Confirm that you are connected and will publish to your UOREGON Arch610 account.

Step 14:
Select "Upload Modified Files" from the Site>Publish Server. The "Upload" window will appear with the appropriate files selected. Click "OK".

Step 15:
Click "Yes" when prompted at the "Synchronize" window.

Step 16:
Your new assignment should now be linked from your homepage and viewable online.
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